Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP)
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 20
- Abstract
- This document provides considerations for alleviating Constrained Application Protocol (CoAP) clients and intermediaries of keeping per-request state. To facilitate this, this document additionally introduces a new, optional CoAP protocol extension for extended token lengths. This document updates RFCs 7252 and 8323 with an extended definition of the "TKL" field in the CoAP message header.
- Publication Date
- 2021-01-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC8974- Link
- https://doi.org/10.17487/RFC8974
- Author(s)
- Klaus HartkeMichael Richardson
- Keyword(s)
- 6TiSCH
Latest version of IETF RFC 8974
Document Versions — IETF RFC 8974
-
▶ IETF RFC 8974 (2021-01-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 7252 [Active*]
- IETF RFC 7641 [Active*]
- IETF RFC 7959 [Active*]
- IETF RFC 8174 [Active*]
- IETF RFC 8323 [Active*]
Bibliographic Reference(s)
- IETF.draft-ietf-6tisch-minimal-security-15 — I-D.ietf-6tisch-minimal-security EXTERNAL
- IETF.draft-ietf-core-echo-request-tag-11 — I-D.ietf-core-echo-request-tag EXTERNAL
- IETF RFC 3610 [Active*]
- IETF RFC 6234 [Active*]
- IETF RFC 7228 [Active*]
- IETF RFC 8613 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC8974.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 8974, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP). Available at https://doi.org/10.17487/RFC8974
Snippet:
IETF RFC 8974, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP). Available at https://doi.org/10.17487/RFC8974
HTML (ISO 690 compliant)
Preview:
IETF RFC 8974, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP). Available at https://doi.org/10.17487/RFC8974
Snippet:
<span class="citation"><cite>IETF RFC 8974</cite>, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP). Available at <a href="https://doi.org/10.17487/RFC8974" target="_blank" rel="noopener">https://doi.org/10.17487/RFC8974</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 8974, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP)
doi: 10.17487/RFC8974
url: https://doi.org/10.17487/RFC8974
doi: 10.17487/RFC8974
url: https://doi.org/10.17487/RFC8974
Snippet:
<li> <cite id="bib-rfc8974">IETF RFC 8974</cite>, Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP) <span class="doi">10.17487/RFC8974</span> </li>
Referenced By
- IETF RFC 9175 [Active*]