Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm
Metadata
- Publisher
- IETF
- Doc Type
- Informational
- Pages
- 13
- Abstract
- This document specifies a padding convention for use with the AES Key Wrap algorithm specified in RFC 3394. This convention eliminates the requirement that the length of the key to be wrapped be a multiple of 64 bits, allowing a key of any practical length to be wrapped. This memo provides information for the Internet community.
- Publication Date
- 2009-09-01
- Status Note
- Informational
- DOI
10.17487/RFC5649- Link
- https://doi.org/10.17487/RFC5649
- Author(s)
- Russ HousleyMorris Dworkin
Latest version of IETF RFC 5649
Document Versions — IETF RFC 5649
-
▶ IETF RFC 5649 (2009-09-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- ISO 8824-1:2002 (ITU-T X.680) [Withdrawn]
- NIST FIPS 197 [Superseded]
- NIST SP 800-38A [Active, Amended]
- National Institute of Standards and Technology, AES Key Wrap Specification, 17 November 2001. http://csrc.nist.gov/groups/ST/toolkit/documents/kms/ AES_key_wrap.pdf EXTERNAL
- IETF RFC 3394 [Active*]
Bibliographic Reference(s)
- ISO.8824-2.2002 — 9 EXTERNAL
- ISO.8824-3.2002 — 10 EXTERNAL
- ISO.8824-4.2002 — 11 EXTERNAL
- Schaad, J. and P. Hoffman, "New ASN.1 Modules for CMS and S/MIME", Work in Progress, August 2009. EXTERNAL
- IETF RFC 3537 [Active*]
- IETF RFC 3565 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC5649.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 5649, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm. Available at https://doi.org/10.17487/RFC5649
Snippet:
IETF RFC 5649, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm. Available at https://doi.org/10.17487/RFC5649
HTML (ISO 690 compliant)
Preview:
IETF RFC 5649, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm. Available at https://doi.org/10.17487/RFC5649
Snippet:
<span class="citation"><cite>IETF RFC 5649</cite>, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm. Available at <a href="https://doi.org/10.17487/RFC5649" target="_blank" rel="noopener">https://doi.org/10.17487/RFC5649</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 5649, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm
doi: 10.17487/RFC5649
url: https://doi.org/10.17487/RFC5649
doi: 10.17487/RFC5649
url: https://doi.org/10.17487/RFC5649
Snippet:
<li> <cite id="bib-rfc5649">IETF RFC 5649</cite>, Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm <span class="doi">10.17487/RFC5649</span> </li>
Referenced By
- IETF RFC 5794 [Active*]
- IETF RFC 5990 [Superseded*]
- IETF RFC 6030 [Active*]
- IETF RFC 8177 [Active*]
- IETF RFC 9838 [Active*]