NETCONF Configuration Protocol
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 95
- Abstract
- The Network Configuration Protocol (NETCONF) defined in this document provides mechanisms to install, manipulate, and delete the configuration of network devices. It uses an Extensible Markup Language (XML)-based data encoding for the configuration data as well as the protocol messages. The NETCONF protocol operations are realized on top of a simple Remote Procedure Call (RPC) layer. [STANDARDS-TRACK]
- Publication Date
- 2006-12-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC4741- Link
- https://doi.org/10.17487/RFC4741
- Author(s)
- Rob Enns
- Keyword(s)
- NETCONF, XML, RPC
Latest version of IETF RFC 4741
Document Versions — IETF RFC 4741
-
▶ IETF RFC 4741 (2006-12-01)THIS DOC [SUPERSEDED] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 3553 [Active*]
- IETF RFC 3688 [Active*]
- IETF RFC 3986 [Active, Amended*]
- IETF RFC 4742 [Superseded*]
- W3C.xml.20001006 — W3C Recommendation, 6 October 2000, October 2000 EXTERNAL
- W3C XML XPath 1 [Superseded]
Bibliographic Reference(s)
- IETF RFC 2865 [Active*]
- IETF RFC 3470 [Active*]
- IETF RFC 4251 [Active*]
- IETF RFC 4346 [Superseded*]
- W3C.xslt.19991116 — XSLT XSL Transforms (XSLT) Version 1.0. Recommendation. J. Clark. November 1999. http://www.w3.org/TR/1999/REC-xslt-19991116.html EXTERNAL
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC4741.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 4741, NETCONF Configuration Protocol. Available at https://doi.org/10.17487/RFC4741
Snippet:
IETF RFC 4741, NETCONF Configuration Protocol. Available at https://doi.org/10.17487/RFC4741
HTML (ISO 690 compliant)
Preview:
IETF RFC 4741, NETCONF Configuration Protocol. Available at https://doi.org/10.17487/RFC4741
Snippet:
<span class="citation"><cite>IETF RFC 4741</cite>, NETCONF Configuration Protocol. Available at <a href="https://doi.org/10.17487/RFC4741" target="_blank" rel="noopener">https://doi.org/10.17487/RFC4741</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 4741, NETCONF Configuration Protocol
doi: 10.17487/RFC4741
url: https://doi.org/10.17487/RFC4741
doi: 10.17487/RFC4741
url: https://doi.org/10.17487/RFC4741
Snippet:
<li> <cite id="bib-rfc4741">IETF RFC 4741</cite>, NETCONF Configuration Protocol <span class="doi">10.17487/RFC4741</span> </li>
Referenced By
- IETF RFC 4743 [Active*]
- IETF RFC 4744 [Active*]
- IETF RFC 5277 [Active*]
- IETF RFC 5539 [Superseded*]
- IETF RFC 5607 [Active*]
- IETF RFC 5717 [Active*]
- IETF RFC 6020 [Active*]
- IETF RFC 6021 [Superseded*]
- IETF RFC 6125 [Superseded*]
- IETF RFC 6241 [Active*]
- IETF RFC 6244 [Active*]