The Camellia Cipher Algorithm and Its Use With IPsec
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 8
- Abstract
- This document describes the use of the Camellia block cipher algorithm in Cipher Block Chaining Mode, with an explicit Initialization Vector, as a confidentiality mechanism within the context of the IPsec Encapsulating Security Payload (ESP). [STANDARDS-TRACK]
- Publication Date
- 2005-12-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC4312- Link
- https://doi.org/10.17487/RFC4312
- Author(s)
- 加藤 明洋Shiho MoriaiMasayuki Kanda
- Keyword(s)
- CBC, Initialization Vector, ESP, IPSEC
Latest version of IETF RFC 4312
Document Versions — IETF RFC 4312
-
▶ IETF RFC 4312 (2005-12-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 3713 [Active*]
- IETF RFC 4303 [Active*]
Bibliographic Reference(s)
- ISBN.9780471117094 — 7. Menezes A. van Oorshot P. Vanstone S. , Handbook of Applied Cryptography , CRC Press , 1997 . EXTERNAL
- NIST FIPS 197 [Superseded]
- NIST SP 800-38A [Active, Amended]
- Information-technology Promotion Agency (IPA), Japan, CRYPTREC. http://www.ipa.go.jp/security/enc/CRYPTREC/ index- e.html. EXTERNAL
- The NESSIE project (New European Schemes for Signatures, Integrity and Encryption), http://www.cosic.esat.kuleuven.ac.be/nessie/ . EXTERNAL
- Camellia web site: http://info.isl.ntt.co.jp/camellia/ . EXTERNAL
- IETF RFC 2119 [Active*]
- IETF RFC 2401 [Superseded*]
- IETF RFC 2409 [Superseded*]
- IETF RFC 2411 [Superseded*]
- IETF RFC 3602 [Active*]
- IETF RFC 3657 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC4312.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 4312, The Camellia Cipher Algorithm and Its Use With IPsec. Available at https://doi.org/10.17487/RFC4312
Snippet:
IETF RFC 4312, The Camellia Cipher Algorithm and Its Use With IPsec. Available at https://doi.org/10.17487/RFC4312
HTML (ISO 690 compliant)
Preview:
IETF RFC 4312, The Camellia Cipher Algorithm and Its Use With IPsec. Available at https://doi.org/10.17487/RFC4312
Snippet:
<span class="citation"><cite>IETF RFC 4312</cite>, The Camellia Cipher Algorithm and Its Use With IPsec. Available at <a href="https://doi.org/10.17487/RFC4312" target="_blank" rel="noopener">https://doi.org/10.17487/RFC4312</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 4312, The Camellia Cipher Algorithm and Its Use With IPsec
doi: 10.17487/RFC4312
url: https://doi.org/10.17487/RFC4312
doi: 10.17487/RFC4312
url: https://doi.org/10.17487/RFC4312
Snippet:
<li> <cite id="bib-rfc4312">IETF RFC 4312</cite>, The Camellia Cipher Algorithm and Its Use With IPsec <span class="doi">10.17487/RFC4312</span> </li>
Referenced By
- IETF RFC 5528 [Active*]
- IETF RFC 5529 [Active*]
- IETF RFC 6071 [Active*]