API Build-data JSON Resources
Theme

Choose how MSRBot.io looks on this device.

Preference is stored in this browser only.

IETF RFC 9908
[ACTIVE]

Clarification and Enhancement of the CSR Attributes Definition in RFC 7030

Metadata

Publisher
IETF
Doc Type
Standard
Pages
22
Abstract
This document updates RFC 7030, "Enrollment over Secure Transport" (EST), clarifying how the Certificate Signing Request (CSR) Attributes Response can be used by an EST server to specify both CSR attribute Object Identifiers (OIDs) and CSR attribute values, particularly X.509 extension values, that the server expects the client to include in a subsequent CSR request. RFC 9148 is derived from RFC 7030 and is also updated. RFC 7030 is ambiguous in its specification of the CSR Attributes Response. This has resulted in implementation challenges and implementor confusion because there was no universal understanding of what was specified. This document clarifies the encoding rules. This document also provides a new straightforward approach: using a template for CSR contents that may be partially filled in by the server. This also allows an EST server to specify a subject Distinguished Name (DN).
Publication Date
2026-01-01
Status Note
Proposed Standard
DOI
10.17487/RFC9908
Link
https://doi.org/10.17487/RFC9908
Author(s)
Michael Richardson
Owen Friel
David von Oheimb
Dan Harkins
Keyword(s)
SubjectAltName, SAN, Certificate Extensions, CSR
Latest version of IETF RFC 9908

Document Versions — IETF RFC 9908

  • ▶ IETF RFC 9908 (2026-01-01)
    THIS DOC [ACTIVE] [LATEST VERSION]
Source Data (JSON)

Full registry record with provenance metadata. Open directly: /api/doc/RFC9908.json

Reference Tree

Explore all references and references to this document, as a navigable tree.

Open Reference Tree
Reference this Doc

Plain text (ISO 690 compliant)

Preview:
IETF RFC 9908, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030. Available at https://doi.org/10.17487/RFC9908
Snippet:
IETF RFC 9908, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030. Available at https://doi.org/10.17487/RFC9908

HTML (ISO 690 compliant)

Preview:
IETF RFC 9908, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030. Available at https://doi.org/10.17487/RFC9908
Snippet:
<span class="citation"><cite>IETF RFC 9908</cite>, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030. Available at <a href="https://doi.org/10.17487/RFC9908" target="_blank" rel="noopener">https://doi.org/10.17487/RFC9908</a></span>

SMPTE Icon SMPTE's HTML Pub

Preview:
IETF RFC 9908, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030
doi: 10.17487/RFC9908
url: https://doi.org/10.17487/RFC9908
Snippet:
<li>
<cite id="bib-rfc9908">IETF RFC 9908</cite>, Clarification and Enhancement of the CSR Attributes Definition in RFC 7030
<span class="doi">10.17487/RFC9908</span>
</li>

Referenced By