Compressed SRv6 Segment List Encoding
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 59
- Abstract
- Segment Routing over IPv6 (SRv6) is the instantiation of Segment Routing (SR) on the IPv6 data plane. This document specifies new flavors for the SRv6 endpoint behaviors defined in RFC 8986, which enable the compression of an SRv6 segment list. Such compression significantly reduces the size of the SRv6 encapsulation needed to steer packets over long segment lists. This document updates RFC 8754 by allowing a Segment List entry in the Segment Routing Header (SRH) to be either an IPv6 address, as specified in RFC 8754, or a REPLACE-CSID container in packed format, as specified in this document.
- Publication Date
- 2025-06-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC9800- Link
- https://doi.org/10.17487/RFC9800
- Author(s)
- Weiqiang ChengClarence FilsfilsZhenbin LiBruno DecraeneFrancois Clad
- Keyword(s)
- Segment Routing, SRv6
Latest version of IETF RFC 9800
Document Versions — IETF RFC 9800
-
▶ IETF RFC 9800 (2025-06-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 8174 [Active*]
- IETF RFC 8200 [Active*]
- IETF RFC 8402 [Active*]
- IETF RFC 8754 [Active*]
- IETF RFC 8986 [Active*]
Bibliographic Reference(s)
- IETF.draft-ietf-idr-bgp-ls-sr-policy-17 — I-D.ietf-idr-bgp-ls-sr-policy EXTERNAL
- IETF.draft-ietf-idr-sr-policy-safi-13 — I-D.ietf-idr-sr-policy-safi EXTERNAL
- ISBN.9780201558029 — GKP94 EXTERNAL
- IETF RFC 4786 [Active*]
- IETF RFC 9252 [Active*]
- IETF RFC 9259 [Active*]
- IETF RFC 9350 [Active*]
- IETF RFC 9352 [Active*]
- IETF RFC 9513 [Active*]
- IETF RFC 9514 [Active*]
- IETF RFC 9602 [Active*]
- IETF RFC 9603 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC9800.json
Amends:
IETF RFC 8754 [Active*]
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 9800, Compressed SRv6 Segment List Encoding. Available at https://doi.org/10.17487/RFC9800
Snippet:
IETF RFC 9800, Compressed SRv6 Segment List Encoding. Available at https://doi.org/10.17487/RFC9800
HTML (ISO 690 compliant)
Preview:
IETF RFC 9800, Compressed SRv6 Segment List Encoding. Available at https://doi.org/10.17487/RFC9800
Snippet:
<span class="citation"><cite>IETF RFC 9800</cite>, Compressed SRv6 Segment List Encoding. Available at <a href="https://doi.org/10.17487/RFC9800" target="_blank" rel="noopener">https://doi.org/10.17487/RFC9800</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 9800, Compressed SRv6 Segment List Encoding
doi: 10.17487/RFC9800
url: https://doi.org/10.17487/RFC9800
doi: 10.17487/RFC9800
url: https://doi.org/10.17487/RFC9800
Snippet:
<li> <cite id="bib-rfc9800">IETF RFC 9800</cite>, Compressed SRv6 Segment List Encoding <span class="doi">10.17487/RFC9800</span> </li>
Referenced By
- IETF RFC 9819 [Active*]