Online Certificate Status Protocol (OCSP) Nonce Extension
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 13
- Abstract
- RFC 8954 imposed size constraints on the optional Nonce extension for the Online Certificate Status Protocol (OCSP). OCSP is used to check the status of a certificate, and the Nonce extension is used to cryptographically bind an OCSP response message to a particular OCSP request message. Some environments use cryptographic algorithms that generate a Nonce value that is longer than 32 octets. This document also modifies the "Nonce" section of RFC 6960 to clearly define and differentiate the encoding format and values for easier implementation and understanding. This document obsoletes RFC 8954, which includes updated ASN.1 modules for OCSP, and updates RFC 6960.
- Publication Date
- 2024-08-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC9654- Link
- https://doi.org/10.17487/RFC9654
- Author(s)
- himanshu sharma
Latest version of IETF RFC 9654
Document Versions — IETF RFC 9654
-
▶ IETF RFC 9654 (2024-08-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 4086 [Active*]
- IETF RFC 5019 [Superseded*]
- IETF RFC 5280 [Active, Amended*]
- IETF RFC 6960 [Active*]
- IETF RFC 8174 [Active*]
- IETF RFC 8954 [Superseded*]
Bibliographic Reference(s)
- IETF RFC 5912 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC9654.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 9654, Online Certificate Status Protocol (OCSP) Nonce Extension. Available at https://doi.org/10.17487/RFC9654
Snippet:
IETF RFC 9654, Online Certificate Status Protocol (OCSP) Nonce Extension. Available at https://doi.org/10.17487/RFC9654
HTML (ISO 690 compliant)
Preview:
IETF RFC 9654, Online Certificate Status Protocol (OCSP) Nonce Extension. Available at https://doi.org/10.17487/RFC9654
Snippet:
<span class="citation"><cite>IETF RFC 9654</cite>, Online Certificate Status Protocol (OCSP) Nonce Extension. Available at <a href="https://doi.org/10.17487/RFC9654" target="_blank" rel="noopener">https://doi.org/10.17487/RFC9654</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 9654, Online Certificate Status Protocol (OCSP) Nonce Extension
doi: 10.17487/RFC9654
url: https://doi.org/10.17487/RFC9654
doi: 10.17487/RFC9654
url: https://doi.org/10.17487/RFC9654
Snippet:
<li> <cite id="bib-rfc9654">IETF RFC 9654</cite>, Online Certificate Status Protocol (OCSP) Nonce Extension <span class="doi">10.17487/RFC9654</span> </li>