A YANG Data Model for RIB Extensions
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 22
- Abstract
- A Routing Information Base (RIB) is a list of routes and their corresponding administrative data and operational state. RFC 8349 defines the basic building blocks for the RIB data model, and this model augments it to support multiple next hops (aka paths) for each route as well as additional attributes.
- Publication Date
- 2023-11-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC9403- Link
- https://doi.org/10.17487/RFC9403
- Author(s)
- Acee LindemYingzhen Qu
- Keyword(s)
- Configuration, IPv6 Router Advertisements, NETCONF RESTCONF, YANG, Routing, RIB
Latest version of IETF RFC 9403
Document Versions — IETF RFC 9403
-
▶ IETF RFC 9403 (2023-11-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 3688 [Active*]
- IETF RFC 6020 [Active*]
- IETF RFC 6241 [Active*]
- IETF RFC 6242 [Active*]
- IETF RFC 6991 [Superseded*]
- IETF RFC 7950 [Active, Amended*]
- IETF RFC 8040 [Active*]
- IETF RFC 8341 [Active*]
- IETF RFC 8342 [Active*]
- IETF RFC 8343 [Active*]
- IETF RFC 8349 [Active*]
- IETF RFC 8446 [Superseded*]
- IETF RFC 9129 [Active*]
- IETF RFC 9130 [Active*]
- W3C XML 1 [Active]
Bibliographic Reference(s)
- IETF RFC 5714 [Active*]
- IETF RFC 7951 [Active*]
- IETF RFC 8340 [Active*]
- IETF RFC 8792 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC9403.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 9403, A YANG Data Model for RIB Extensions. Available at https://doi.org/10.17487/RFC9403
Snippet:
IETF RFC 9403, A YANG Data Model for RIB Extensions. Available at https://doi.org/10.17487/RFC9403
HTML (ISO 690 compliant)
Preview:
IETF RFC 9403, A YANG Data Model for RIB Extensions. Available at https://doi.org/10.17487/RFC9403
Snippet:
<span class="citation"><cite>IETF RFC 9403</cite>, A YANG Data Model for RIB Extensions. Available at <a href="https://doi.org/10.17487/RFC9403" target="_blank" rel="noopener">https://doi.org/10.17487/RFC9403</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 9403, A YANG Data Model for RIB Extensions
doi: 10.17487/RFC9403
url: https://doi.org/10.17487/RFC9403
doi: 10.17487/RFC9403
url: https://doi.org/10.17487/RFC9403
Snippet:
<li> <cite id="bib-rfc9403">IETF RFC 9403</cite>, A YANG Data Model for RIB Extensions <span class="doi">10.17487/RFC9403</span> </li>
Referenced By
- IETF draft-acee-rtgwg-yang-rib-extend-06 [Active*]