Using TLS to Secure QUIC
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 52
- Abstract
- This document describes how Transport Layer Security (TLS) is used to secure QUIC.
- Publication Date
- 2021-05-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC9001- Link
- https://doi.org/10.17487/RFC9001
- Author(s)
- Martin ThomsonSean Turner
- Keyword(s)
- Opportunistic Security, Plaintext Quic
Latest version of IETF RFC 9001
Document Versions — IETF RFC 9001
-
▶ IETF RFC 9001 (2021-05-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- NIST FIPS 180-4 [Active]
- NIST FIPS 197 [Superseded]
- IETF RFC 2119 [Active*]
- IETF RFC 4086 [Active*]
- IETF RFC 5116 [Active*]
- IETF RFC 5869 [Active*]
- IETF RFC 7301 [Active*]
- IETF RFC 8174 [Active*]
- IETF RFC 8439 [Active*]
- IETF RFC 8446 [Superseded*]
- IETF RFC 8447 [Active*]
- IETF RFC 9000 [Active*]
- IETF RFC 9002 [Active*]
Bibliographic Reference(s)
- 10.1007-3-540-36492-7_7 — CCM-ANALYSIS EXTERNAL
- 10.1007-978-3-030-26948-7_9 — NAN EXTERNAL
- 10.1145-3243734.3243816 — GCM-MU EXTERNAL
- IETF.draft-ietf-quic-http-34 EXTERNAL
- ISBN.9781466570269 — IMC EXTERNAL
- Luykx, A. and K. Paterson, "Limits on Authenticated Encryption Use in TLS", 28 August 2017, <https://www.isg.rhul.ac.uk/~kp/TLS-AEbounds.pdf>. EXTERNAL
- Fischlin, M., Günther, F., and C. Janson, "Robust Channels: Handling Unreliable Networks in the Record Layers of QUIC and DTLS 1.3", 16 May 2020, <https://eprint.iacr.org/2020/718>. EXTERNAL
- IETF RFC 20 [Active*]
- IETF RFC 2818 [Superseded*]
- IETF RFC 5280 [Active, Amended*]
- IETF RFC 8470 [Active*]
- IETF RFC 8740 [Superseded*]
- IETF RFC 8879 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC9001.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 9001, Using TLS to Secure QUIC. Available at https://doi.org/10.17487/RFC9001
Snippet:
IETF RFC 9001, Using TLS to Secure QUIC. Available at https://doi.org/10.17487/RFC9001
HTML (ISO 690 compliant)
Preview:
IETF RFC 9001, Using TLS to Secure QUIC. Available at https://doi.org/10.17487/RFC9001
Snippet:
<span class="citation"><cite>IETF RFC 9001</cite>, Using TLS to Secure QUIC. Available at <a href="https://doi.org/10.17487/RFC9001" target="_blank" rel="noopener">https://doi.org/10.17487/RFC9001</a></span>
SMPTE's HTML Pub
Preview:
Snippet:
<li> <cite id="bib-rfc9001">IETF RFC 9001</cite>, Using TLS to Secure QUIC <span class="doi">10.17487/RFC9001</span> </li>
Referenced By
- IETF RFC 8999 [Active*]
- IETF RFC 9000 [Active*]
- IETF RFC 9002 [Active*]
- IETF RFC 9221 [Active*]
- IETF RFC 9250 [Active*]
- IETF RFC 9261 [Active*]
- IETF RFC 9325 [Active*]
- IETF RFC 9331 [Active*]
- IETF RFC 9369 [Active*]
- IETF RFC 9411 [Active*]
- IETF RFC 9443 [Active*]
- IETF RFC 9525 [Active*]
- IETF RFC 9846 [Active*]
- IETF RFC 9852 [Active*]