Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 12
- Abstract
- A Path Computation Element (PCE) can compute Traffic Engineering (TE) paths through a network; these paths are subject to various constraints. Currently, TE paths are Label Switched Paths (LSPs) that are set up using the RSVP-TE signaling protocol. However, other TE path setup methods are possible within the PCE architecture. This document proposes an extension to the PCE Communication Protocol (PCEP) to allow support for different path setup methods over a given PCEP session.
- Publication Date
- 2018-07-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC8408- Link
- https://doi.org/10.17487/RFC8408
- Author(s)
- Siva SivabalanJeff TantsuraIna MineiRobert VargaJonathan Hardwick
Latest version of IETF RFC 8408
Document Versions — IETF RFC 8408
-
▶ IETF RFC 8408 (2018-07-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 5440 [Active*]
- IETF RFC 8174 [Active*]
- IETF RFC 8231 [Active*]
- IETF RFC 8281 [Active*]
Bibliographic Reference(s)
- IETF.draft-ietf-pce-segment-routing-12 — PCEP-SR-EXT EXTERNAL
- IETF RFC 4655 [Active*]
- IETF RFC 4657 [Active*]
- IETF RFC 5706 [Active*]
- IETF RFC 8126 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC8408.json
Amended by:
IETF RFC 8664 [Active*]
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 8408, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages. Available at https://doi.org/10.17487/RFC8408
Snippet:
IETF RFC 8408, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages. Available at https://doi.org/10.17487/RFC8408
HTML (ISO 690 compliant)
Preview:
IETF RFC 8408, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages. Available at https://doi.org/10.17487/RFC8408
Snippet:
<span class="citation"><cite>IETF RFC 8408</cite>, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages. Available at <a href="https://doi.org/10.17487/RFC8408" target="_blank" rel="noopener">https://doi.org/10.17487/RFC8408</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 8408, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages
doi: 10.17487/RFC8408
url: https://doi.org/10.17487/RFC8408
doi: 10.17487/RFC8408
url: https://doi.org/10.17487/RFC8408
Snippet:
<li> <cite id="bib-rfc8408">IETF RFC 8408</cite>, Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages <span class="doi">10.17487/RFC8408</span> </li>
Referenced By
- IETF RFC 8664 [Active*]
- IETF RFC 9050 [Active*]
- IETF RFC 9059 [Active*]
- IETF RFC 9603 [Active*]
- IETF RFC 9826 [Active*]
- IETF RFC 9862 [Active*]