Interface to the Routing System (I2RS) Traceability: Framework and Information Model
Metadata
- Publisher
- IETF
- Doc Type
- Informational
- Pages
- 17
- Abstract
- This document describes a framework for traceability in the Interface to the Routing System (I2RS) and the information model for that framework. It specifies the motivation, requirements, and use cases, and defines an information model for recording interactions between elements implementing the I2RS protocol. This framework provides a consistent tracing interface for components implementing the I2RS architecture to record what was done, by which component, and when. It aims to improve the management of I2RS implementations, and can be used for troubleshooting, auditing, forensics, and accounting purposes.
- Publication Date
- 2016-06-01
- Status Note
- Informational
- DOI
10.17487/RFC7922- Link
- https://doi.org/10.17487/RFC7922
- Author(s)
- Joe ClarkeGonzalo SalgueiroCarlos Pignataro
- Keyword(s)
- I2RS
Latest version of IETF RFC 7922
Document Versions — IETF RFC 7922
-
▶ IETF RFC 7922 (2016-06-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 3339 [Active*]
- IETF RFC 5424 [Active*]
- IETF RFC 7921 [Active*]
- IETF RFC 7923 [Active*]
Bibliographic Reference(s)
- IETF.draft-ietf-i2rs-rib-info-model-08 — RIBINFO EXTERNAL
- IETF RFC 6536 [Superseded*]
- IETF RFC 7920 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC7922.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 7922, Interface to the Routing System (I2RS) Traceability: Framework and Information Model. Available at https://doi.org/10.17487/RFC7922
Snippet:
IETF RFC 7922, Interface to the Routing System (I2RS) Traceability: Framework and Information Model. Available at https://doi.org/10.17487/RFC7922
HTML (ISO 690 compliant)
Preview:
IETF RFC 7922, Interface to the Routing System (I2RS) Traceability: Framework and Information Model. Available at https://doi.org/10.17487/RFC7922
Snippet:
<span class="citation"><cite>IETF RFC 7922</cite>, Interface to the Routing System (I2RS) Traceability: Framework and Information Model. Available at <a href="https://doi.org/10.17487/RFC7922" target="_blank" rel="noopener">https://doi.org/10.17487/RFC7922</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 7922, Interface to the Routing System (I2RS) Traceability: Framework and Information Model
doi: 10.17487/RFC7922
url: https://doi.org/10.17487/RFC7922
doi: 10.17487/RFC7922
url: https://doi.org/10.17487/RFC7922
Snippet:
<li> <cite id="bib-rfc7922">IETF RFC 7922</cite>, Interface to the Routing System (I2RS) Traceability: Framework and Information Model <span class="doi">10.17487/RFC7922</span> </li>
Referenced By
- IETF RFC 7923 [Active*]
- IETF RFC 8241 [Active*]
- IETF RFC 8242 [Active*]