Certificate Transparency
Metadata
- Publisher
- IETF
- Doc Type
- Experimental
- Pages
- 27
- Abstract
- This document describes an experimental protocol for publicly logging the existence of Transport Layer Security (TLS) certificates as they are issued or observed, in a manner that allows anyone to audit certificate authority (CA) activity and notice the issuance of suspect certificates as well as to audit the certificate logs themselves. The intent is that eventually clients would refuse to honor certificates that do not appear in a log, effectively forcing CAs to add all issued certificates to the logs. Logs are network services that implement the protocol operations for submissions and queries that are defined in this document.
- Publication Date
- 2013-06-01
- Status Note
- Experimental
- DOI
10.17487/RFC6962- Link
- https://doi.org/10.17487/RFC6962
- Author(s)
- Ben LaurieAdam LangleyEmilia Kasper
- Keyword(s)
- TLS Certificates
Latest version of IETF RFC 6962
Document Versions — IETF RFC 6962
-
▶ IETF RFC 6962 (2013-06-01)THIS DOC [SUPERSEDED] [LATEST VERSION]
Superseded by:
- RFC9162 NOT IN REGISTRY
Bibliographic Reference(s)
- NIST FIPS 180-4 [Active]
- NIST FIPS 186-3 [Withdrawn]
- Crosby, S. and D. Wallach, "Efficient Data Structures for Tamper-Evident Logging", Proceedings of the 18th USENIX Security Symposium, Montreal, August 2009, < http://static.usenix.org/event/sec09/ tech/full_papers/crosby.pdf >. EXTERNAL
- IETF RFC 2560 [Superseded*]
- IETF RFC 3447 [Superseded*]
- IETF RFC 4627 [Superseded*]
- IETF RFC 4648 [Active*]
- IETF RFC 5246 [Superseded*]
- IETF RFC 5280 [Active, Amended*]
- IETF RFC 5905 [Active*]
- IETF RFC 6066 [Active*]
- W3C.html401.19991224 — [HTML-4.01] REC-html401-19991224, W3C Recommendation: HTML 4.01 Specification (December 24 th , 1999). EXTERNAL
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC6962.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 6962, Certificate Transparency. Available at https://doi.org/10.17487/RFC6962
Snippet:
IETF RFC 6962, Certificate Transparency. Available at https://doi.org/10.17487/RFC6962
HTML (ISO 690 compliant)
Preview:
IETF RFC 6962, Certificate Transparency. Available at https://doi.org/10.17487/RFC6962
Snippet:
<span class="citation"><cite>IETF RFC 6962</cite>, Certificate Transparency. Available at <a href="https://doi.org/10.17487/RFC6962" target="_blank" rel="noopener">https://doi.org/10.17487/RFC6962</a></span>
SMPTE's HTML Pub
Preview:
Snippet:
<li> <cite id="bib-rfc6962">IETF RFC 6962</cite>, Certificate Transparency <span class="doi">10.17487/RFC6962</span> </li>
Referenced By
- IETF RFC 7258 [Active*]
- IETF RFC 7624 [Active*]
- IETF RFC 8446 [Superseded*]