Parallel NFS (pNFS) Block/Volume Layout
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 28
- Abstract
- Parallel NFS (pNFS) extends Network File Sharing version 4 (NFSv4) to allow clients to directly access file data on the storage used by the NFSv4 server. This ability to bypass the server for data access can increase both performance and parallelism, but requires additional client functionality for data access, some of which is dependent on the class of storage used. The main pNFS operations document specifies storage-class-independent extensions to NFS; this document specifies the additional extensions (primarily data structures) for use of pNFS with block- and volume-based storage. [STANDARDS-TRACK]
- Publication Date
- 2010-01-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC5663- Link
- https://doi.org/10.17487/RFC5663
- Author(s)
- David L. BlackStephen FridellaJason Glasgow
- Keyword(s)
- NFSv4
Latest version of IETF RFC 5663
Document Versions — IETF RFC 5663
-
▶ IETF RFC 5663 (2010-01-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF Trust, "Legal Provisions Relating to IETF Documents", http://trustee.ietf.org/docs/IETF-Trust-License-Policy.pdf , November 2008. EXTERNAL
- IETF RFC 2119 [Active*]
- IETF RFC 4506 [Active*]
- IETF RFC 5661 [Superseded*]
Bibliographic Reference(s)
- EMC Corporation, "EMC Celerra Multi-Path File System (MPFS)", EMC Data Sheet, http://www.emc.com/collateral/software/data-sheet/ h2006-celerra-mpfs-mpfsi.pdf . EXTERNAL
- SNIA, "Storage Management Initiative Specification (SMI-S) v1.4", http://www.snia.org/tech_activities/standards/ curr_standards/smi/SMI-S_Technical_Position_v1.4.0r4.zip . EXTERNAL
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC5663.json
Amended by:
RFC6688 NOT IN REGISTRY
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 5663, Parallel NFS (pNFS) Block/Volume Layout. Available at https://doi.org/10.17487/RFC5663
Snippet:
IETF RFC 5663, Parallel NFS (pNFS) Block/Volume Layout. Available at https://doi.org/10.17487/RFC5663
HTML (ISO 690 compliant)
Preview:
IETF RFC 5663, Parallel NFS (pNFS) Block/Volume Layout. Available at https://doi.org/10.17487/RFC5663
Snippet:
<span class="citation"><cite>IETF RFC 5663</cite>, Parallel NFS (pNFS) Block/Volume Layout. Available at <a href="https://doi.org/10.17487/RFC5663" target="_blank" rel="noopener">https://doi.org/10.17487/RFC5663</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 5663, Parallel NFS (pNFS) Block/Volume Layout
doi: 10.17487/RFC5663
url: https://doi.org/10.17487/RFC5663
doi: 10.17487/RFC5663
url: https://doi.org/10.17487/RFC5663
Snippet:
<li> <cite id="bib-rfc5663">IETF RFC 5663</cite>, Parallel NFS (pNFS) Block/Volume Layout <span class="doi">10.17487/RFC5663</span> </li>
Referenced By
- IETF RFC 5661 [Superseded*]