Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 9
- Abstract
- The Internet Small Computer Systems Interface (iSCSI) protocol, described in RFC 3720, allows for extension items to the protocol in the form of Private or Public Extension Keys. This document describes a Public Extension Key for the purpose of enhancing iSCSI supportability. The key accomplishes this objective by allowing iSCSI nodes to communicate architecture details during the iSCSI login sequence. The receiving node can then use this information for enhanced logging and support. This document updates RFC 3720 to allow iSCSI extension items to be defined by standards track RFCs and experimental RFCs in addition to informational RFCs. [STANDARDS-TRACK]
- Publication Date
- 2007-04-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC4850- Link
- https://doi.org/10.17487/RFC4850
- Author(s)
- Dave Wysochanski
- Keyword(s)
- TCP
Latest version of IETF RFC 4850
Document Versions — IETF RFC 4850
-
▶ IETF RFC 4850 (2007-04-01)THIS DOC [SUPERSEDED] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2119 [Active*]
- IETF RFC 3720 [Superseded*]
Bibliographic Reference(s)
- IETF RFC 2616 [Superseded*]
- IETF RFC 3723 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC4850.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 4850, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture. Available at https://doi.org/10.17487/RFC4850
Snippet:
IETF RFC 4850, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture. Available at https://doi.org/10.17487/RFC4850
HTML (ISO 690 compliant)
Preview:
IETF RFC 4850, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture. Available at https://doi.org/10.17487/RFC4850
Snippet:
<span class="citation"><cite>IETF RFC 4850</cite>, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture. Available at <a href="https://doi.org/10.17487/RFC4850" target="_blank" rel="noopener">https://doi.org/10.17487/RFC4850</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 4850, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture
doi: 10.17487/RFC4850
url: https://doi.org/10.17487/RFC4850
doi: 10.17487/RFC4850
url: https://doi.org/10.17487/RFC4850
Snippet:
<li> <cite id="bib-rfc4850">IETF RFC 4850</cite>, Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture <span class="doi">10.17487/RFC4850</span> </li>
Referenced By
- IETF RFC 7143 [Active*]