Common Format and MIME Type for Comma-Separated Values (CSV) Files
Metadata
- Publisher
- IETF
- Doc Type
- Informational
- Pages
- 8
- Abstract
- This RFC documents the format used for Comma-Separated Values (CSV) files and registers the associated MIME type "text/csv". This memo provides information for the Internet community.
- Publication Date
- 2005-10-01
- Status Note
- Informational
- DOI
10.17487/RFC4180- Link
- https://doi.org/10.17487/RFC4180
- Author(s)
- Yakov Shafranovich
Latest version of IETF RFC 4180
Document Versions — IETF RFC 4180
-
▶ IETF RFC 4180 (2005-10-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- IETF RFC 2046 [Active, Amended*]
- IETF RFC 2048 [Superseded*]
- IETF RFC 2234 [Superseded*]
Bibliographic Reference(s)
- Repici, J., "HOW-TO: The Comma Separated Value (CSV) File Format", 2004, < http://www.creativyst.com/Doc/Articles/CSV/CSV01.htm >. EXTERNAL
- Edoceo, Inc., "CSV Standard File Format", 2004, < http://www.edoceo.com/utilis/csv-file-format.php >. EXTERNAL
- Rodger, R. and O. Shanaghy, "Documentation for Ricebridge CSV Manager", February 2005, < http://www.ricebridge.com/products/csvman/reference.htm >. EXTERNAL
- Raymond, E., "The Art of Unix Programming, Chapter 5", September 2003, < http://www.catb.org/~esr/writings/taoup/html/ch05s02.html >. EXTERNAL
- IETF RFC 793 [Superseded*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC4180.json
Amended by:
RFC7111 — RFC7111 EXTERNAL
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 4180, Common Format and MIME Type for Comma-Separated Values (CSV) Files. Available at https://doi.org/10.17487/RFC4180
Snippet:
IETF RFC 4180, Common Format and MIME Type for Comma-Separated Values (CSV) Files. Available at https://doi.org/10.17487/RFC4180
HTML (ISO 690 compliant)
Preview:
IETF RFC 4180, Common Format and MIME Type for Comma-Separated Values (CSV) Files. Available at https://doi.org/10.17487/RFC4180
Snippet:
<span class="citation"><cite>IETF RFC 4180</cite>, Common Format and MIME Type for Comma-Separated Values (CSV) Files. Available at <a href="https://doi.org/10.17487/RFC4180" target="_blank" rel="noopener">https://doi.org/10.17487/RFC4180</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 4180, Common Format and MIME Type for Comma-Separated Values (CSV) Files
doi: 10.17487/RFC4180
url: https://doi.org/10.17487/RFC4180
doi: 10.17487/RFC4180
url: https://doi.org/10.17487/RFC4180
Snippet:
<li> <cite id="bib-rfc4180">IETF RFC 4180</cite>, Common Format and MIME Type for Comma-Separated Values (CSV) Files <span class="doi">10.17487/RFC4180</span> </li>
Referenced By
- IETF RFC 5070 [Superseded*]
- IETF RFC 7970 [Active*]
- IETF RFC 9193 [Active*]