Internet Printing Protocol/1.1: IPP URL Scheme
Metadata
- Publisher
- IETF
- Doc Type
- Standard
- Pages
- 16
- Abstract
- This memo defines the "ipp" URL (Uniform Resource Locator) scheme. This memo updates IPP/1.1: Encoding and Transport (RFC 2910), by expanding and clarifying Section 5, "IPP URL Scheme", of RFC 2910. An "ipp" URL is used to specify the network location of a print service that supports the IPP Protocol (RFC 2910), or of a network resource (for example, a print job) managed by such a print service. [STANDARDS-TRACK]
- Publication Date
- 2003-04-01
- Status Note
- Proposed Standard
- DOI
10.17487/RFC3510- Link
- https://doi.org/10.17487/RFC3510
- Author(s)
- Robert G. HerriotIra McDonald
- Keyword(s)
- IPP-E-T, IPP, Application, Media Type, URL
Latest version of IETF RFC 3510
Document Versions — IETF RFC 3510
-
▶ IETF RFC 3510 (2003-04-01)THIS DOC [ACTIVE] [LATEST VERSION]
Normative Reference(s)
- ANSI/INCITS X3.4:1986 (R1997) [Active]
- IETF RFC 2234 [Superseded*]
- IETF RFC 2396 [Superseded*]
- IETF RFC 2616 [Superseded*]
- IETF RFC 2732 [Superseded*]
- IETF RFC 2910 [Superseded*]
- IETF RFC 2911 [Superseded*]
Bibliographic Reference(s)
- IANA MIME Media Types Registry. ftp://ftp.iana.org/in-notes/iana/assignments/media- types/ ... EXTERNAL
- IANA Port Numbers Registry. ftp://ftp.iana.org/in- notes/iana/assignments/port-numbers EXTERNAL
- IETF RFC 2569 [Active*]
- IETF RFC 2717 [Superseded*]
- IETF RFC 2718 [Superseded*]
- RFC3196 — RFC3196 EXTERNAL
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC3510.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 3510, Internet Printing Protocol/1.1: IPP URL Scheme. Available at https://doi.org/10.17487/RFC3510
Snippet:
IETF RFC 3510, Internet Printing Protocol/1.1: IPP URL Scheme. Available at https://doi.org/10.17487/RFC3510
HTML (ISO 690 compliant)
Preview:
IETF RFC 3510, Internet Printing Protocol/1.1: IPP URL Scheme. Available at https://doi.org/10.17487/RFC3510
Snippet:
<span class="citation"><cite>IETF RFC 3510</cite>, Internet Printing Protocol/1.1: IPP URL Scheme. Available at <a href="https://doi.org/10.17487/RFC3510" target="_blank" rel="noopener">https://doi.org/10.17487/RFC3510</a></span>
SMPTE's HTML Pub
Preview:
IETF RFC 3510, Internet Printing Protocol/1.1: IPP URL Scheme
doi: 10.17487/RFC3510
url: https://doi.org/10.17487/RFC3510
doi: 10.17487/RFC3510
url: https://doi.org/10.17487/RFC3510
Snippet:
<li> <cite id="bib-rfc3510">IETF RFC 3510</cite>, Internet Printing Protocol/1.1: IPP URL Scheme <span class="doi">10.17487/RFC3510</span> </li>
Referenced By
- IETF RFC 7472 [Active*]
- IETF RFC 8010 [Active*]
- IETF RFC 8011 [Active*]