IP Multicast and Firewalls
Metadata
- Publisher
- IETF
- Doc Type
- Informational
- Pages
- 12
- Abstract
- In this document, we discuss the issues surrounding the traversal of IP multicast traffic across a firewall, and describe possible ways in which a firewall can implement and control this traversal. We also explain why some firewall mechanisms - such as SOCKS - that were designed specifically for unicast traffic, are less appropriate for multicast. This memo provides information for the Internet community.
- Publication Date
- 1999-05-01
- Status Note
- Informational
- DOI
10.17487/RFC2588- Link
- https://doi.org/10.17487/RFC2588
- Author(s)
- Ross Finlayson
- Keyword(s)
- IPSEC, Routers, Traffic
Latest version of IETF RFC 2588
Document Versions — IETF RFC 2588
-
▶ IETF RFC 2588 (1999-05-01)THIS DOC [ACTIVE] [LATEST VERSION]
Bibliographic Reference(s)
- Finlayson, R., "The UDP Multicast Tunneling Protocol" , Work in Progress. EXTERNAL
- Djahandari, K., Sterne, D. F., "An MBone Proxy for an Application Gateway Firewall" IEEE Symposium on Security and Privacy, 1997. EXTERNAL
- Freed, N. and K. Carosso, "An Internet Firewall Transparency Requirement", Work in Progress. EXTERNAL
- Fenner, B., "Domain Wide Multicast Group Membership Reports" , Work in Progress. EXTERNAL
- Chouinard, D., "SOCKS V5 UDP and Multicast Extensions" , Work in Progress. EXTERNAL
- IETF RFC 1112 [Active*]
- IETF RFC 1889 [Superseded*]
- IETF RFC 1928 [Active*]
- IETF RFC 2326 [Superseded*]
- IETF RFC 2327 [Superseded*]
- IETF RFC 2365 [Active*]
Source Data (JSON)
Full registry record with provenance metadata. Open directly: /api/doc/RFC2588.json
Reference Tree
Explore all references and references to this document, as a navigable tree.
Open Reference TreeReference this Doc
Plain text (ISO 690 compliant)
Preview:
IETF RFC 2588, IP Multicast and Firewalls. Available at https://doi.org/10.17487/RFC2588
Snippet:
IETF RFC 2588, IP Multicast and Firewalls. Available at https://doi.org/10.17487/RFC2588
HTML (ISO 690 compliant)
Preview:
IETF RFC 2588, IP Multicast and Firewalls. Available at https://doi.org/10.17487/RFC2588
Snippet:
<span class="citation"><cite>IETF RFC 2588</cite>, IP Multicast and Firewalls. Available at <a href="https://doi.org/10.17487/RFC2588" target="_blank" rel="noopener">https://doi.org/10.17487/RFC2588</a></span>
SMPTE's HTML Pub
Preview:
Snippet:
<li> <cite id="bib-rfc2588">IETF RFC 2588</cite>, IP Multicast and Firewalls <span class="doi">10.17487/RFC2588</span> </li>
Referenced By
- IETF RFC 3170 [Active*]
- IETF RFC 6272 [Active*]