Current document root:
IETF RFC 9330
Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: Architecture
IETF • Informational • [Active*]
Click a document below to open its own reference tree.
Level 1 — direct dependents (docs that cite this doc)
- IETF RFC 9331[Active*]
- IETF RFC 9332[Active*]
- IETF RFC 9768[Active*]
Level 1 — direct references (docs this doc cites)
- 10.1002-j.1538-7305.1978.tb02135.xMcIlroy78EXTERNAL
- 10.1016-j.jnca.2016.03.021AFCDEXTERNAL
- 10.1109-LANMAN.2019.8847054COBALTEXTERNAL
- 10.1109-LCN.2017.22LEDBAT_AQMEXTERNAL
- 10.1117-12.554462NASA04EXTERNAL
- 10.1145-1015467.1015499BufferSizeEXTERNAL
- 10.1145-1111322.1111336Dukkipati06EXTERNAL
- 10.1145-2663716.2663730Hohlfeld14EXTERNAL
- 10.1145-2910017.2910633L4Sdemo16EXTERNAL
- 10.1145-3404868.3406669Nadas20EXTERNAL
- 10.48550-arXiv.1904.07044QDynEXTERNAL
- 10.48550-arXiv.2107.01003BDPdataEXTERNAL
- 10.48550-arXiv.2209.01078L4Seval22EXTERNAL
- GITHUB.EricssonResearch.screamSCReAM-L4SEXTERNAL
- GITHUB.google.bbrBBRv2EXTERNAL
- IETF draft-briscoe-conex-policing-01[Active*]
- IETF.draft-briscoe-docsis-q-protection-06I-D.briscoe-docsis-q-protectionEXTERNAL
- IETF.draft-briscoe-iccrg-prague-congestion-control-01I-D.briscoe-iccrg-prague-congestion-controlEXTERNAL
- IETF.draft-briscoe-tsvwg-l4s-diffserv-02I-D.briscoe-tsvwg-l4s-diffservEXTERNAL
- IETF draft-cardwell-iccrg-bbr-congestion-control-02[Active*]
- IETF.draft-ietf-tcpm-accurate-ecn-22I-D.ietf-tcpm-accurate-ecnEXTERNAL
- IETF.draft-ietf-tsvwg-ecn-encap-guidelines-17I-D.ietf-tsvwg-ecn-encap-guidelinesEXTERNAL
- IETF.draft-ietf-tsvwg-l4sops-03I-D.ietf-tsvwg-l4sopsEXTERNAL
- IETF.draft-ietf-tsvwg-nqb-15I-D.ietf-tsvwg-nqbEXTERNAL
- IETF.draft-ietf-tsvwg-rfc6040update-shim-15I-D.ietf-tsvwg-rfc6040update-shimEXTERNAL
- IETF.draft-mathis-iccrg-relentless-tcp-00I-D.mathis-iccrg-relentless-tcpEXTERNAL
- IETF.draft-morton-tsvwg-codel-approx-fair-01I-D.morton-tsvwg-codel-approx-fairEXTERNAL
- IETF.draft-sridharan-tcpm-ctcp-02CTCPEXTERNAL
- IETF.draft-stewart-tsvwg-sctpecn-05SCTP-ECNEXTERNAL
- IETF RFC 2475[Active*]
- IETF RFC 2698[Active*]
- IETF RFC 2884[Active*]
- IETF RFC 3168[Active*]
- IETF RFC 3246[Active*]
- IETF RFC 3540[Active*]
- IETF RFC 3649[Active*]
- IETF RFC 4340[Active*]
- IETF RFC 4774[Active*]
- IETF RFC 4960[Superseded*]
- IETF RFC 5033[Superseded*]
- IETF RFC 5348[Active*]
- IETF RFC 5670[Active*]
- IETF RFC 5681[Active*]
- IETF RFC 6040[Active*]
- IETF RFC 6679[Active*]
- IETF RFC 6817[Active*]
- IETF RFC 6973[Active*]
- IETF RFC 7560[Active*]
- IETF RFC 7567[Active*]
- IETF RFC 7665[Active*]
- IETF RFC 7713[Active*]
- IETF RFC 8033[Active*]
- IETF RFC 8034[Active*]
- RFC8170RFC8170EXTERNAL
- IETF RFC 8257[Active*]
- IETF RFC 8290[Active*]
- RFC8298RFC8298EXTERNAL
- IETF RFC 8311[Active*]
- IETF RFC 8312[Superseded*]
- RFC8404RFC8404EXTERNAL
- IETF RFC 8511[Active*]
- IETF RFC 8888[Active*]
- IETF RFC 8985[Active*]
- IETF RFC 9000[Active*]
- IETF RFC 9113[Active*]
- IETF RFC 9331[Active*]
- IETF RFC 9332[Active*]
- IETF RFC 970[Active*]
- Jacobson, V. and M. Karels, "Congestion Avoidance and Control", Laurence Berkeley Labs Technical Report , November 1988, <https://ee.lbl.gov/papers/congavoid.pdf>.EXTERNAL
- Briscoe, B., De Schepper, K., Albisser, O., Misund, J., Tilmans, O., Kühlewind, M., and A.S. Ahmed, "Implementing the 'TCP Prague' Requirements for Low Latency Low Loss Scalable Throughput (L4S)", Proceedings Linux Netdev 0x13, March 2019, <https://www.netdevconf.org/0x13/session.html?talk-tcp-prague-l4s>.EXTERNAL
- "Videos used in IETF dispatch WG 'Ultra-Low Queuing Delay for All Apps' slot", <https://riteproject.eu/dctth/#1511dispatchwg>.EXTERNAL
- Raaen, K. and T-M. Grønli, "Latency Thresholds for Usability in Games: A Survey", Norsk IKT-konferanse for forskning og utdanning (Norwegian ICT conference for research and education), 2014, <http://ojs.bibsys.no/index.php/NIK/article/view/9/6>.EXTERNAL
- White, G., "Active Queue Management Algorithms for DOCSIS 3.0: A Simulation Study of CoDel, SFQ-CoDel and PIE in DOCSIS 3.0 Networks", CableLabs Technical Report, April 2013, <https://www.cablelabs.com/wp-content/uploads/2013/11/Active_Queue_Management_Algorithms_DOCSIS_3_0.pdf>.EXTERNAL
- Meenan, P., "Optimizing HTTP/2 prioritization with BBR and tcp_notsent_lowat", Cloudflare Blog, October 2018, <https://blog.cloudflare.com/http-2-prioritization-with-nginx/>.EXTERNAL
- CableLabs, "MAC and Upper Layer Protocols Interface (MULPI) Specification, CM-SP-MULPIv3.1", Data-Over-Cable Service Interface Specifications DOCSIS 3.1 Version i17 or later, 21 January 2019, <https://specification-search.cablelabs.com/CM-SP-MULPIv3.1>.EXTERNAL
- Albisser, O., De Schepper, K., Briscoe, B., Tilmans, O., and H. Steen, "DUALPI2 - Low Latency, Low Loss and Scalable (L4S) AQM", Proceedings of Linux Netdev 0x13, March 2019, <https://www.netdevconf.org/0x13/session.html?talk-DUALPI2-AQM>.EXTERNAL
- Rajiullah, M., "Towards a Low Latency Internet: Understanding and Solutions", Dissertation, Karlstad University, 2015, <https://www.diva-portal.org/smash/get/diva2:846109/FULLTEXT01.pdf>.EXTERNAL
- "fq_codel: generalise ce_threshold marking for subset of traffic", commit dfcb63ce1de6b10b, October 2021, <https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net-next.git/commit/?id=dfcb63ce1de6b10b>.EXTERNAL
- Austrheim, M., "Implementing immediate forwarding for 4G in a network simulator", Master's Thesis, University of Oslo, 2018.EXTERNAL