{
  "$schema": "/api/schemas/documents.schema.json",
  "apiVersion": "1.1.0",
  "lastModified": "2026-10-21T23:42:32.551Z",
  "sourcePath": "src/main/data/docs",
  "docId": "RFC8578",
  "document": {
    "abstract": "This document presents use cases for diverse industries that have in common a need for \"deterministic flows\". \"Deterministic\" in this context means that such flows provide guaranteed bandwidth, bounded latency, and other properties germane to the transport of time-sensitive data. These use cases differ notably in their network topologies and specific desired behavior, providing as a group broad industry context for Deterministic Networking (DetNet). For each use case, this document will identify the use case, identify representative solutions used today, and describe potential improvements that DetNet can enable.",
    "abstract$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML abstract",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "authors": [
      {
        "name": "Ethan Grossman"
      }
    ],
    "authors$meta": {
      "confidence": "high",
      "note": "Parsed from Datatracker doc page article:author (profile full names)",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "docId": "RFC8578",
    "docId$meta": {
      "confidence": "high",
      "note": "Derived from RFC number or Datatracker identifier",
      "originalValue": null,
      "source": "resolved",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "docLabel": "IETF RFC 8578",
    "docLabel$meta": {
      "confidence": "high",
      "note": "Constructed from provider and document identifier",
      "originalValue": null,
      "source": "resolved",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "docNumber": "8578",
    "docNumber$meta": {
      "confidence": "high",
      "note": "From the RFC index entry (rfc-index.xml <doc-id>)",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "docTitle": "Deterministic Networking Use Cases",
    "docTitle$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML title",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "docType": "Informational",
    "docType$meta": {
      "confidence": "high",
      "note": "Mapped from Datatracker std_level or RFC status text",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "doi": "10.17487/RFC8578",
    "doi$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML doi",
      "originalValue": null,
      "source": "resolved",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "href": "https://doi.org/10.17487/RFC8578",
    "href$meta": {
      "confidence": "high",
      "note": "Derived from DOI (https://doi.org/<doi>)",
      "originalValue": null,
      "source": "resolved",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "keywords": [
      "DetNet",
      "AVB",
      "TSN",
      "SRP"
    ],
    "keywords$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML keywords",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "pages": "97",
    "pages$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML page-count",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "publicationDate": "2019-05-01",
    "publicationDate$meta": {
      "confidence": "high",
      "note": "Parsed from RFC index XML date",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "publisher": "IETF",
    "publisher$meta": {
      "confidence": "high",
      "note": "Static: provider",
      "originalValue": null,
      "source": "parsed",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "references": {
      "bibliographic": [
        "10.3390-en7063900",
        "IETF.draft-ietf-6tisch-architecture-20",
        "ASHRAE.135.1995",
        "IETF.draft-bas-usecase-detnet-00",
        "IETF.draft-ietf-6tisch-coap-03",
        "IETF.draft-svshah-tsvwg-deterministic-forwarding-04",
        "IETF.draft-thubert-6tisch-4detnet-01",
        "IETF.draft-ietf-detnet-architecture-13",
        "IETF.draft-gunther-detnet-proaudio-req-01",
        "IETF.draft-zha-detnet-use-case-00",
        "IETF.draft-korhonen-detnet-telreq-00",
        "IETF.draft-ietf-detnet-security-04",
        "IETF.draft-wetterwald-detnet-utilities-reqs-02",
        "IEEE.STD1904.3.2015",
        "IEC.60834",
        "IEC.60870-5-101",
        "IEC.61400-25",
        "IEEE.STD1588.2008",
        "IEEE.STD1646.2004",
        "IEEE.STD1722.2016",
        "IEEE.STD1815",
        "IEEE.STD1914.3",
        "IEEE.STD802.11.2016",
        "IEEE.STD802.15.2015",
        "IEEE.STD802.1AS",
        "IEEE.STD802.1CM.2018",
        "IETF.draft-ietf-6tisch-6top-interface-04",
        "ISO.14543-3",
        "IEC.61158",
        "RFC3031",
        "RFC3411",
        "RFC3985",
        "RFC4553",
        "RFC5086",
        "RFC5087",
        "RFC5905",
        "RFC6550",
        "RFC6551",
        "RFC7554",
        "RFC8169",
        "10.1109-NOMS.2012.6211945",
        "IETF.draft-kh-spring-ip-ran-use-case-02",
        "IETF.draft-wang-6tisch-6top-sublayer-04",
        "T-REC-G.8261.2013",
        "IETF.draft-ietf-tictoc-1588overmpls-07",
        "3GPP.TR-38.801.201704",
        "3GPP.TS-23.401.201903",
        "3GPP.TS-23.501.201903",
        "3GPP.TS-25.104.201901",
        "3GPP.TS-36.104.201901",
        "3GPP.TS-36.133.201901",
        "3GPP.TS-36.211.201901",
        "3GPP.TS-36.300.201901",
        "IEC.62591.2016",
        "IEC.61850-5",
        "ISO.8802-3",
        "IEC.TR61850-90-12",
        "IEC.62357-200.2015",
        "IEC.61850-9-3",
        "RFC7322",
        "orphan/RFC8578/h:d1626458",
        "orphan/RFC8578/h:95c6502a",
        "orphan/RFC8578/h:e0502fe6",
        "orphan/RFC8578/h:abe3983e",
        "orphan/RFC8578/h:87a7ec5d",
        "orphan/RFC8578/h:d4518618",
        "orphan/RFC8578/h:e1321940",
        "orphan/RFC8578/h:d2c9536f",
        "orphan/RFC8578/h:f0d3d609",
        "orphan/RFC8578/h:4d0736b7",
        "orphan/RFC8578/h:633dea71",
        "orphan/RFC8578/h:efdf81c1",
        "orphan/RFC8578/h:fd26466c",
        "orphan/RFC8578/h:d01fbcbd",
        "orphan/RFC8578/h:fefd3b75",
        "orphan/RFC8578/h:06af21ea",
        "orphan/RFC8578/h:8e7463e9",
        "orphan/RFC8578/h:8ad01e13",
        "orphan/RFC8578/h:5d67fd25",
        "orphan/RFC8578/h:4b94a83d",
        "orphan/RFC8578/h:5ff2db0b",
        "orphan/RFC8578/h:f83c2449",
        "orphan/RFC8578/h:d10196dd",
        "orphan/RFC8578/h:b6e369b3"
      ],
      "bibliographic$meta": {
        "confidence": "medium",
        "flag": "MIXED_REF_LAYOUT_RISK anchored=79 proseBlocks=114 skippedAnchorBlocks=93",
        "note": "Parsed from RFC HTML references/informative sections",
        "originalValue": [
          "10.3390-en7063900",
          "IETF.draft-ietf-6tisch-architecture-20",
          "ASHRAE.135.1995",
          "IETF.draft-bas-usecase-detnet-00",
          "IETF.draft-ietf-6tisch-coap-03",
          "IETF.draft-svshah-tsvwg-deterministic-forwarding-04",
          "IETF.draft-thubert-6tisch-4detnet-01",
          "IETF.draft-ietf-detnet-architecture-13",
          "IETF.draft-gunther-detnet-proaudio-req-01",
          "IETF.draft-zha-detnet-use-case-00",
          "IETF.draft-korhonen-detnet-telreq-00",
          "IETF.draft-ietf-detnet-security-04",
          "IETF.draft-wetterwald-detnet-utilities-reqs-02",
          "IEEE.STD1904.3.2015",
          "IEC.60834",
          "IEC.60870-5-101",
          "IEC.61400-25",
          "IEEE.STD1646",
          "IEEE.STD1914.3",
          "IEEE.STD802.11.2016",
          "IEEE.STD802.15.2015",
          "IEEE.STD802.1AS",
          "IEEE.STD802.1CM",
          "IETF.draft-ietf-6tisch-6top-interface-04",
          "ISO.14543-3",
          "IEC.61158",
          "RFC3031",
          "RFC3411",
          "RFC3985",
          "RFC4553",
          "RFC5086",
          "RFC5087",
          "RFC5905",
          "RFC6550",
          "RFC6551",
          "RFC7554",
          "RFC8169",
          "10.1109-NOMS.2012.6211945",
          "IETF.draft-kh-spring-ip-ran-use-case-02",
          "IETF.draft-wang-6tisch-6top-sublayer-04",
          "T-REC-G.8261.2013",
          "IETF.draft-ietf-tictoc-1588overmpls-07",
          "3GPP.TR-38.801.201704",
          "3GPP.TS-23.401.201903",
          "3GPP.TS-23.501.201903",
          "3GPP.TS-25.104.201901",
          "3GPP.TS-36.104.201901",
          "3GPP.TS-36.133.201901",
          "3GPP.TS-36.211.201901",
          "3GPP.TS-36.300.201901",
          "IEC.62591.2016",
          "IEC.61850-5",
          "ISO.8802-3",
          "IEC.62357-200.2015",
          "IEC.61850-9-3",
          "RFC7322",
          "orphan/RFC8578/h:d1626458",
          "orphan/RFC8578/h:95c6502a",
          "orphan/RFC8578/h:e0502fe6",
          "orphan/RFC8578/h:abe3983e",
          "orphan/RFC8578/h:87a7ec5d",
          "orphan/RFC8578/h:d4518618",
          "orphan/RFC8578/h:e1321940",
          "orphan/RFC8578/h:d2c9536f",
          "orphan/RFC8578/h:c7b57cc2",
          "orphan/RFC8578/h:e717172b",
          "orphan/RFC8578/h:80b06f20",
          "orphan/RFC8578/h:f0d3d609",
          "orphan/RFC8578/h:4d0736b7",
          "orphan/RFC8578/h:633dea71",
          "orphan/RFC8578/h:efdf81c1",
          "orphan/RFC8578/h:fd26466c",
          "orphan/RFC8578/h:d01fbcbd",
          "orphan/RFC8578/h:fefd3b75",
          "orphan/RFC8578/h:06af21ea",
          "orphan/RFC8578/h:8e7463e9",
          "orphan/RFC8578/h:8ad01e13",
          "orphan/RFC8578/h:5d67fd25",
          "orphan/RFC8578/h:4b94a83d",
          "orphan/RFC8578/h:5ff2db0b",
          "orphan/RFC8578/h:f83c2449",
          "orphan/RFC8578/h:d10196dd",
          "orphan/RFC8578/h:fc5eb964",
          "orphan/RFC8578/h:b6e369b3"
        ],
        "overridden": true,
        "reviewRequired": true,
        "source": "parsed",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T23:42:32.551Z",
        "version": "extractDocs.js@commit:cc353c041d14"
      }
    },
    "resolvedHref": "https://www.rfc-editor.org/info/rfc8578/",
    "resolvedHref$meta": {
      "confidence": "high",
      "note": "Final URL resolved via URL redirect verification",
      "originalValue": null,
      "source": "resolved",
      "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
      "updated": "2026-10-21T16:58:03.987Z",
      "version": "extractDocs.js@commit:2c1e5418e9d0"
    },
    "status": {
      "active": true,
      "active$meta": {
        "confidence": "high",
        "note": "Derived from supersession relationship fields",
        "originalValue": null,
        "source": "resolved",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T16:58:03.987Z",
        "version": "extractDocs.js@commit:2c1e5418e9d0"
      },
      "errataExist": false,
      "errataExist$meta": {
        "confidence": "high",
        "note": "Derived from presence of errata links on RFC/Datatracker pages",
        "originalValue": null,
        "source": "parsed",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T16:58:03.987Z",
        "version": "extractDocs.js@commit:2c1e5418e9d0"
      },
      "latestVersion": true,
      "latestVersion$meta": {
        "confidence": "high",
        "note": "Derived from supersession relationship fields",
        "originalValue": null,
        "source": "resolved",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T16:58:03.987Z",
        "version": "extractDocs.js@commit:2c1e5418e9d0"
      },
      "statusNote": "Informational",
      "statusNote$meta": {
        "confidence": "high",
        "note": "Mapped from Datatracker doc.json std_level",
        "originalValue": null,
        "source": "parsed",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T16:58:03.987Z",
        "version": "extractDocs.js@commit:2c1e5418e9d0"
      },
      "superseded": false,
      "superseded$meta": {
        "confidence": "high",
        "note": "Derived from supersession relationship fields",
        "originalValue": null,
        "source": "resolved",
        "sourceUrl": "https://www.rfc-editor.org/info/rfc8578/",
        "updated": "2026-10-21T16:58:03.987Z",
        "version": "extractDocs.js@commit:2c1e5418e9d0"
      }
    }
  }
}